Author Topic: Trying to update bots to 1.27 and get ip banned  (Read 3811 times)

ping

  • Newbie
  • *
  • Posts: 41
  • Karma: +2/-1
    • View Profile
Trying to update bots to 1.27 and get ip banned
« on: March 15, 2016, 05:57:24 am »
Hi all,

Blizzard have finally released a patch after 5 years. Anyway, I've updated the war3.exe and the two dll files and am getting ip banned from battle.net? Is this happening to anyone else?

Regards.

Grief-Code

  • Average Member
  • ***
  • Posts: 149
  • Karma: +25/-8
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #1 on: March 15, 2016, 10:11:50 am »
I assume you need to host with one IP per bot.
Have been running in the same issue as soon as i put more bots on one IP.

ping

  • Newbie
  • *
  • Posts: 41
  • Karma: +2/-1
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #2 on: March 15, 2016, 06:51:56 pm »
Bots are connecting now, however they're occasionally disconnecting from europe, asia and uswest.

Code: [Select]
[BNET: Asia] connecting to server [asia.battle.net] on port 6112
[BNET: Asia] using cached server IP address 121.254.164.27
[BNET: Asia] connected
[TCPSOCKET] closed by remote host
[BNET: Asia] disconnected from battle.net
[BNET: Asia] waiting 90 seconds to reconnect

...

[BNET: Europe] connecting to server [europe.battle.net] on port 6112
[BNET: Europe] using cached server IP address 5.42.181.12
[BNET: Europe] connected
[BNET: Europe] attempting to auth as Warcraft III: The Frozen Throne
[BNET: Europe] cd keys accepted
[BNET: Europe] username [VFG-HostbotEU] accepted
[BNET: Europe] using battle.net logon type (for official battle.net servers only)
[BNET: Europe] logon successful
[TCPSOCKET] closed by remote host
[BNET: Europe] disconnected from battle.net
[BNET: Europe] waiting 90 seconds to reconnect

This is happening to almost all of my bots on the one IP address. Any suggestions on how to fix this without adding another ip address?

Lamer

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-2
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #3 on: March 16, 2016, 01:02:27 pm »
After new patch, I got an error:
Code: [Select]
logon failed - game version is too old, disconnectingI updated war3.exe, War3Patch.mpq and dll files, but my bot still not connected:
Code: [Select]
logon failed - game version is invalid, disconnectingWhat's wrong?
« Last Edit: March 16, 2016, 01:04:43 pm by Lamer »

ping

  • Newbie
  • *
  • Posts: 41
  • Karma: +2/-1
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #4 on: March 16, 2016, 06:48:42 pm »
You need to change where you see 26 to 27 in the bot's configuration.

Lamer

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-2
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #5 on: March 16, 2016, 07:19:19 pm »
I don't see 26 in the bot's configuration. I found 26 in default.cfg:
Code: [Select]
# bnet3_custom_war3version = 26but seems like this line is only for pvpgn
P.S. I use original ghost++
UPD I added this line, now works
« Last Edit: March 16, 2016, 08:13:11 pm by Lamer »

Grief-Code

  • Average Member
  • ***
  • Posts: 149
  • Karma: +25/-8
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #6 on: March 17, 2016, 02:32:54 am »
Bots are connecting now, however they're occasionally disconnecting from europe, asia and uswest.

Code: [Select]
[BNET: Asia] connecting to server [asia.battle.net] on port 6112
[BNET: Asia] using cached server IP address 121.254.164.27
[BNET: Asia] connected
[TCPSOCKET] closed by remote host
[BNET: Asia] disconnected from battle.net
[BNET: Asia] waiting 90 seconds to reconnect

...

[BNET: Europe] connecting to server [europe.battle.net] on port 6112
[BNET: Europe] using cached server IP address 5.42.181.12
[BNET: Europe] connected
[BNET: Europe] attempting to auth as Warcraft III: The Frozen Throne
[BNET: Europe] cd keys accepted
[BNET: Europe] username [VFG-HostbotEU] accepted
[BNET: Europe] using battle.net logon type (for official battle.net servers only)
[BNET: Europe] logon successful
[TCPSOCKET] closed by remote host
[BNET: Europe] disconnected from battle.net
[BNET: Europe] waiting 90 seconds to reconnect

This is happening to almost all of my bots on the one IP address. Any suggestions on how to fix this without adding another ip address?

Yea this is the classic IP ban, just start them up directly after to see the message. It's not shown at the first close of the socket.
When I have some time, I will look more into details about that issue, it can be also the case that the queuewaittime need to be adjusted and that causes it. They have sadly provided only a really useless changelog and changes compared to the hype they started around. Cannot even relate why compatibility is a major release.

ping

  • Newbie
  • *
  • Posts: 41
  • Karma: +2/-1
    • View Profile
Re: Trying to update bots to 1.27 and get ip banned
« Reply #7 on: March 17, 2016, 10:07:22 am »
I thought it would be an IP ban. The bots have been working fine for the last few years up until the most recent patch, but everything seems to be working properly after leaving the bots off for several hours. Thank you for taking the time to answer :)